Cómo iniciar automáticamente la base de datos de muestra ORCLCDB en Oracle Linux 8.5

En un tutorial anterior vimos cómo instalar la base de datos de muestra Oracle 19c ORCLCDB en una máquina virtual Oracle Linux 8.5. Después de la instalación, tuve que iniciar manualmente la instancia de base de datos y el “Oracle Listener”. Veremos ahora en esta página cómo iniciar automáticamente estos dos elementos.

Iniciar ORCLCDB
Iniciar ORCLCDB

Después de reiniciar la máquina virtual, intenté conectarme al “Oracle Enterprise Manager” con un navegador web, pero recibí el siguiente mensaje de error:

Error: Unable to connect
Error: Unable to connect

La explicación era que la base de datos ORCLCDB y el “Oracle Listener” no estaban iniciados. Podría haberlos iniciado manualmente como lo hice en esta página, pero preferí configurarlos para iniciarlos automáticamente con el arranque de la máquina virtual.

Primero abrí el archivo “/etc/oratab” para ver si la instancia estaba configurada para iniciarse automáticamente:

/etc/oratab file
/etc/oratab file

Y, como se ver en la captura de pantalla superior, el valor del último parámetro para la entrada ORCLCDB es ‘N‘, lo que significa que esta instancia no debería iniciarse automáticamente.

La solución era simple, modifiqué el valor a ‘Y‘ con el editor vi:

vi /etc/oratab
vi /etc/oratab

Luego verifiqué si el servicio utilizado para iniciar la instancia ORCLCDB y el “Oracle Listener” estaba habilitado con el comando “systemctl is-enabled oracledb_ORCLCDB-19c”:

systemctl is-enabled oracledb_ORCLCDB-19c
systemctl is-enabled oracledb_ORCLCDB-19c

Y como era de esperar estaba desactivado. La solución era otra vez muy sencilla: lo habilité con el comando “sudo systemctl enable oracledb_ORCLCDB-19c” y verifiqué el resultado con el comando “systemctl is-enabled oracledb_ORCLCDB-19c”:

sudo systemctl enable oracledb_ORCLCDB-19c
sudo systemctl enable oracledb_ORCLCDB-19c

El servicio estaba ahora habilitado, así que reinicié la máquina virtual para verificar si podía conectarme al “Oracle Enterprise Manager” después del reinicio:

https://192.168.1.16:5500/em
https://192.168.1.16:5500/em

Y esta vez todo funcionaba correctamente: después de unos segundos, el navegador web mostró la ventana de inicio de sesión. Esto significaba que la instancia de la base de datos y el “Oracle Listener” se habían iniciado automáticamente.

Descargo de responsabilidad

La información contenida en este sitio web es solo para fines de información general. Tratamos de mantener esta información actualizada y correcta, pero no asumimos ninguna responsabilidad por errores u omisiones en el contenido del sitio web. El Portal no garantiza ni asume responsabilidad alguna respecto a los posibles daños y perjuicios causados por el uso y utilización de la información o de los gráficos contenidos en el sitio web.

La página Cómo iniciar automáticamente la base de datos de muestra ORCLCDB en Oracle Linux 8.5 ha sido originalmente publicada en MyBIJourney

Todas las marcas comerciales mencionadas pertenecen a sus respectivos propietarios.
FacebookTwitterPinterestWhatsAppMail