Cómo instalar la base de datos de muestra de Oracle 19c

En un tutorial anterior vimos cómo instalar el servidor de base de datos Oracle 19c en Oracle Linux 8.5 VM. Ahora vamos a ver cómo instalar y configurar una base de datos de muestra Oracle 19c utilizando los scripts proporcionados.

Instalar ORCLCDB
Instalar ORCLCDB

Seguía conectado como usuario root y, como puede verse en la captura de pantalla siguiente, la instalación de Oracle 19c mostraba el script de configuración que había que ejecutar para crear y configurar una base de datos de Oracle de muestra. Así que ejecuté el comando “/etc/init.d/oracledb_ORCLCDB-19c configure” como usuario root:

/etc/init.d/oracledb_ORCLCDB-19c configure
/etc/init.d/oracledb_ORCLCDB-19c configure

El script comenzó a crear la base de datos de muestra…

Terminando la creación de la base de datos
Terminando la creación de la base de datos

… y siguió unos minutos más…

Éxito de la configuración de la base de datos de muestra
Éxito de la configuración de la base de datos de muestra

… hasta que terminó. Al final, tardó un poco menos de 15 minutos para crear y configurar la base de datos de muestra Oracle en la máquina virtual.

El nombre de la base de datos (SID) era ORCLCDB y el script de configuración recomendaba cambiar las contraseñas mediante el comando “sqlplus /as sysdba” como usuario oracle.

Así que inicié una sesión como usuario oracle y modifiqué el archivo “.bashrc” con el comando “vi .bashrc” para incluir las variables ORACLE necesarias para acceder a la nueva base de datos de muestra Oracle:

vi .bashrc
vi .bashrc

Traté de conectarme a la BBDD ORCLCDB recién creada con el comando “sqlplus” pero recibí un mensaje “Connected to an idle instance” (Conectado a una instancia inactiva):

Connected to an idle instance
Connected to an idle instance

Ejecuté el comando “startup” para iniciar la instancia de base de datos:

Iniciar la instancia
Iniciar la instancia

Una vez que la instancia de la base de datos de muestra había arrancado, pude cambiar las contraseñas de los usuarios system y sys. Ejecuté el comando “ALTER USER user_name IDENTIFIED BY new_password;” reemplazando “user_name” y “new_password” con el nombre del usuario y una contraseña válida (oculta en la captura de pantalla siguiente):

sqlplus / as sysdba
sqlplus / as sysdba

Intenté conectarme al “Enterprise Manager” con la URL “https://192.168.1.15:5500/em/” en un navegador web, pero recibí un error:

Error: Unable to connect
Error: Unable to connect

Parecía que algunos de los servicios de Oracle no se estaban ejecutando, así que verifiqué el estado del “Oracle Listener” con el comando “lsnrctl status“:

lsnrctl status
lsnrctl status

Y claramente faltaba algo, así que traté de iniciar el “Oracle Listener” manualmente con el comando “lsnrctl start“:

lsnrctl start
lsnrctl start

Parecía funcionar, así que traté de conectarme al “Oracle Enterprise Manager” otra vez, pero esta vez recibí un mensaje de advertencia:

Warning: Potential Security Risk Ahead
Warning: Potential Security Risk Ahead

Hice clic en el botón “Advanced” (Avanzado) y descubrí que el problema estaba relacionado con un certificado autofirmado. No era un problema con esta máquina virtual que solo se iba a usar para hacer unas pruebas, así que hice clic en el botón “Accept the Risk and Continue” (Aceptar el riesgo y continuar):

The certificate is not trusted because it is self -signed.
The certificate is not trusted because it is self -signed.

Y ahora tenía acceso a la ventana de inicio de sesión del “Oracle Enterprise Manager”:

Conexión al Oracle Enterprise Manager
Conexión al Oracle Enterprise Manager

Introduce la contraseña del usuario sys y hice clic en el botón “Log in” (Iniciar sesión):

Conectado al Oracle Enterprise Manager
Conectado al Oracle Enterprise Manager

Y estaba ahora conectado al “Oracle Enterprise Manager” de la instancia ORCLCDB y todo funcionaba. ¡Disponía ahora de una base de datos de muestra para hacer las pruebas!

Descargo de responsabilidad

La información contenida en este sitio web es solo para fines de información general. Tratamos de mantener esta información actualizada y correcta, pero no asumimos ninguna responsabilidad por errores u omisiones en el contenido del sitio web. El Portal no garantiza ni asume responsabilidad alguna respecto a los posibles daños y perjuicios causados por el uso y utilización de la información o de los gráficos contenidos en el sitio web.

La página Cómo instalar la base de datos de muestra de Oracle 19c ha sido originalmente publicada en MyBIJourney

Todas las marcas comerciales mencionadas pertenecen a sus respectivos propietarios.
FacebookTwitterPinterestWhatsAppMail