Comment démarrer automatiquement la base de données exemple ORCLCDB sur Oracle Linux 8.5

Dans un tutoriel précédent, nous avons vu comment installer la base de données exemple Oracle 19c ORCLCDB dans une machine virtuelle Oracle Linux 8.5. Après l’installation, j’avais dû démarrer manuellement l’instance de la base de données et l’“Oracle Listener”. Nous allons voir dans ce tutoriel comment démarrer automatiquement ces deux éléments au démarrage de l’OS.

Démarrer ORCLCDB
Démarrer ORCLCDB

Après avoir redémarré la machine virtuelle, j’ai essayé de me connecter à l’“Oracle Enterprise Manager” avec un navigateur Web, mais j’ai reçu le message d’erreur suivant :

Error: Unable to connect
Error: Unable to connect

L’explication était que la base de données ORCLCDB et l’“Oracle Listener” n’étaient pas démarrés après un redémarrage de l’OS. J’aurais pu les démarrer manuellement comme je l’avais fait dans cette page mais j’ai préféré les configurer pour qu’ils démarrent automatiquement au démarrage de la machine virtuelle.

Tout d’abord, j’ai ouvert le fichier “/etc/oratab” pour voir si l’instance était configurée pour démarrer automatiquement :

/etc/oratab file
/etc/oratab file

Et comme vous pouvez le voir dans la capture d’écran précédente, la valeur de dernier paramètre pour l’entrée ORCLCDB est ‘N‘, ce qui signifie que cette instance ne doit pas démarrer automatiquement.

La solution était simple, j’ai remplacé cette valeur par ‘Y‘ en utilisant l’éditeur vi :

vi /etc/oratab
vi /etc/oratab

Ensuite, j’ai vérifié si le service utilisé pour démarrer l’instance ORCLCDB et l’“Oracle Listener” était activé avec la commande “systemctl is-enabled oracledb_ORCLCDB-19c” :

systemctl is-enabled oracledb_ORCLCDB-19c
systemctl is-enabled oracledb_ORCLCDB-19c

Et il était désactivé comme je m’y attendais. La solution était à nouveau très simple : je l’ai activé avec la commande “sudo systemctl enable oracledb_ORCLCDB-19c” et j’ai vérifié le résultat avec la commande “systemctl is-enabled oracledb_ORCLCDB-19c” :

sudo systemctl enable oracledb_ORCLCDB-19c
sudo systemctl enable oracledb_ORCLCDB-19c

Le service était maintenant activé, j’ai donc redémarré la machine virtuelle pour vérifier si je pouvais me connecter à l’“Oracle Enterprise Manager” après un redémarrage :

https://192.168.1.16:5500/em
https://192.168.1.16:5500/em

Et cette fois-ci tout a fonctionné correctement : au bout de quelques secondes, le navigateur web a affiché la fenêtre de connexion. Cela signifiait que l’instance de base de données et l’“Oracle Listener” avaient démarré automatiquement.

Clause de non-responsabilité

Les informations contenues dans ce site Web sont uniquement à des fins d’information générale. Nous essayons de maintenir ces informations à jour et correctes, mais nous n’offrons aucune garantie d’aucune sorte quant à l’exhaustivité, l’exactitude ou la fiabilité du contenu du site Web. En aucun cas, nous ne serons responsables de toute perte ou dommage de quelque nature que ce soit résultant de l’utilisation de ce site Web.

Cette page Comment démarrer automatiquement la base de données exemple ORCLCDB sur Oracle Linux 8.5 a été initialement publiée sur MyBIJourney

Toutes les marques déposées sont la propriété de leurs propriétaires respectifs.
FacebookTwitterPinterestWhatsAppMail