Comment installer la base de données exemple Oracle 19c

Dans un tutoriel précédent, nous avons vu comment installer le serveur de base de données Oracle 19c dans Oracle Linux 8.5 VM. Nous allons maintenant voir comment installer et configurer une base de données exemple Oracle à l’aide des scripts fournis.

Installer ORCLCDB
Installer ORCLCDB

J’étais toujours connecté en tant qu’utilisateur root et comme vous pouvez le voir dans la capture d’écran suivante, le script d’installation d’Oracle 19c affichait le script de configuration à exécuter pour créer et configurer la base de données exemple. J’ai donc exécuté la commande “/etc/init.d/oracledb_ORCLCDB-19c configure” comme utilisateur root:

/etc/init.d/oracledb_ORCLCDB-19c configure
/etc/init.d/oracledb_ORCLCDB-19c configure

Le script a commencé à créer de base de données exemple…

En train de terminer la création de la base de données
En train de terminer la création de la base de données

… et il a continué quelques minutes de plus …

Succés de la configuration de la base de données exemple
Succés de la configuration de la base de données exemple

… jusqu’à ce qu’il termine. Il a pris finalement un peu moins de 15 minutes pour créer et configurer la base de données exemple Oracle dans la machine virtuelle.

Le nom de la base de données (SID) était ORCLCDB et le script de configuration recommandait de modifier les mots de passe avec la commande “sqlplus / as sysdba” en tant qu’utilisateur oracle.

Je me suis donc connecté en tant qu’utilisateur oracle et j’ai modifié le fichier “.bashrc” avec la commande “vi .bashrc” afin d’inclure les variables ORACLE requises pour accéder à la base de données exemple Oracle :

vi .bashrc
vi .bashrc

J’ai essayé de me connecter à la base de données ORCLCDB nouvellement créée avec la commande “sqlplus” mais j’ai reçu le message “Connected to an idle instance” (Connecté à une instance inactive):

Connected to an idle instance
Connected to an idle instance

J’ai exécuté la commande “startup” pour démarrer l’instance de base de données :

Démarrer l’instance
Démarrer l’instance

Une fois l’instance de base de données exemple démarrée, je pouvais modifier les mots de passe des utilisateurs system et sys. J’ai exécuté la commande “ALTER USER user_name IDENTIFIED BY new_password ;” en remplaçant “user_name” et “new_password” par le nom d’utilisateur et un mot de passe valide (occulté dans la capture d’écran suivante) :

sqlplus / as sysdba
sqlplus / as sysdba

J’ai essayé de me connecter à la page web “Oracle Enterprise Manager” avec l’URL “https://192.168.1.15:5500/em/” mais j’ai reçu une erreur :

Error: Unable to connect
Error: Unable to connect

Il semblait que certains des services Oracle ne fonctionnaient pas, j’ai donc vérifié l’état de l’“Oracle Listener” avec la commande “lsnrctl status” :

lsnrctl status
lsnrctl status

Et il manquait clairement quelque chose, j’ai essayé de démarrer l’“Oracle Listener” manuellement avec la commande “lsnrctl start” :

lsnrctl start
lsnrctl start

Cela semblait fonctionner, j’ai donc essayé de me connecter à nouveau à l’“Oracle Enterprise Manager” et cette fois-ci j’ai reçu un message d’avertissement :

Warning: Potential Security Risk Ahead
Warning: Potential Security Risk Ahead

J’ai cliqué sur le bouton “Advanced” (Avancé) et j’ai vu que le problème était lié à un certificat auto-signé. Ce n’était pas un problème pour cette machine virtuelle qui ne serait utilisée que pour effectuer quelques tests, j’ai donc cliqué sur le bouton “Accept the Risk and Continue” (Accepter le risque et continuer):

The certificate is not trusted because it is self -signed.
The certificate is not trusted because it is self -signed.

Et je pouvais maintenant avoir accès à la fenêtre de connexion d’”Oracle Enterprise Manager” :

Connexion à l’Oracle Enterprise Manager
Connexion à l’Oracle Enterprise Manager

J’ai entré le mot de passe de l’utilisateur sys et j’ai cliqué sur le bouton “Log in” (Connexion):

Connecté à l'Oracle Enterprise Manager
Connecté à l’Oracle Enterprise Manager

Et j’étais maintenant connecté à l’“Oracle Enterprise Manager” de l’instance ORCLCDB et tout fonctionnait parfaitement. J’avais maintenant une base de données exemple avec laquelle j’allais pouvoir faire les tests !

Clause de non-responsabilité

Les informations contenues dans ce site Web sont uniquement à des fins d’information générale. Nous essayons de maintenir ces informations à jour et correctes, mais nous n’offrons aucune garantie d’aucune sorte quant à l’exhaustivité, l’exactitude ou la fiabilité du contenu du site Web. En aucun cas, nous ne serons responsables de toute perte ou dommage de quelque nature que ce soit résultant de l’utilisation de ce site Web.

Cette page Comment installer la base de données exemple Oracle 19c a été initialement publiée sur MyBIJourney

Toutes les marques déposées sont la propriété de leurs propriétaires respectifs.
FacebookTwitterPinterestWhatsAppMail